Mettre à jour ESXI facilement

Cet article est un complément à celui-ci.

Avant toute chose, attention, il est possible que votre machine nécessite des drivers particuliers, notamment en ce qui concerne les drivers de carte réseau, le mieux est de chercher sur le Net si votre carte est compatible ou si celle-ci a besoin de drivers particuliers.

Dans un premier temps, pour connaître les derniers patchs disponibles pour votre version d’ESXi vous pouvez regarder ces liens

Pour la suite on va prendre comme exemple VMware ESXi 6.0, car c’est la version sur laquelle j’ai fait la mise à jour récemment.

À l’heure ou j’écris ces lignes quand on regarde le dernier patch dispo pour ESXi 6.0 c’est celui-ci « ESXi-6.0.0-20160104001-standard » (Build 3380124, ou encore appelé ESXi 6.0 update 1b)

Connectez-vous en SSH à votre hôte ESXi et tapez simplement (passez votre hôte en mode maintenance avant ça peut-être judicieux) :

Évidemment, changez « ESXi-6.0.0-20160104001-standard » avec la version voulue.

Si vous avez un message d’erreur avec « Broken pipe » vous n’avez qu’à retenter la commande et ça devrait passer.

Ici c’est le stade où il est possible que vous ayez une étape supplémentaire en fonction de votre matériel, chez OVH (SoYouStart) le matériel est assez standard et fonctionne bien sur ESXi 6.0 même si OVH ne propose pas forcément les images d’installation pour ESXi 6.0.

Il ne vous reste plus qu’à envoyer un « reboot » dans votre console SSH.

Enfin, pour finir, si vous vous demandez si ces MAJ sont « cumulatives », oui elles le sont si vous utilisez bien le mot « profile » dans la ligne de commande pour mettre a jour, si vous remplacez profile par « vib » il y a des chances que vous n’ayez que les correctifs du patch choisit (et donc pas ceux des patchs précédents), bref avec la méthode que je donne oui c’est cumulatif :p

Vous avez aimé cet article ? Partagez-le :)

Facebook Google Plus Twitter Linkedin email

2 réflexions au sujet de « Mettre à jour ESXI facilement »

  1. bonjour j’ai essayé votre methode et j’ai ce message : [Exception]
    You attempted to install an image profile which would have resulted in the remo val of VIBs [‘Brocade_bootbank_scsi-bfa_3.2.3.0-1OEM.550.0.0.1198610’, ‘QLogic_b ootbank_net-qlcnic_5.5.177-1OEM.550.0.0.1198611’, ‘IBM_bootbank_fwupdate_550-3AC E02AUS’, ‘IBM_bootbank_ibmcustomization_4.0-1’, ‘IBM_bootbank_pciinfo_550-ESXI05 ACN’, ‘IBM_bootbank_filetrans_550-3ACE02AUS’, ‘IBM_bootbank_fupb_5.5-13D08A’, ‘B rocade_bootbank_net-bna_3.2.3.0-1OEM.550.0.0.1198610’, ‘IBM_bootbank_soibms_550- ESXI05ACN’, ‘VMware_bootbank_vmware-fdm_5.5.0-3142196’, ‘IBM_bootbank_immpassthr u_550-3ACE02AUS’, ‘VMware_bootbank_net-qlge_3.0.0.57-1vmw.550.0.0.1198611’, ‘IBM _bootbank_concretejob_550-3ACE02AUS’, ‘IBM_bootbank_hwckvm_550-ESXI05ACN’]. If t his is not what you intended, you may use the esxcli software profile update com mand to preserve the VIBs above. If this is what you intended, please use the — ok-to-remove option to explicitly allow the removal.
    Please refer to the log file for more details.

    Vous pouvez m’aider?

    • Vous avez tenter de mettre a niveau de 5.5 vers 6.0 ?

      Si oui c’est ecrit qu’il faut ajouter –ok-to-remove dans la command line, attention néemoins les drivers entre 5.5 et 6.0 ne sont pas tout a fait les mêmes le mieux et de tester cette manip sur une machine fraichement installé

      Cdt

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *